Did I mention that I HATE lawn mowers - Page 2 - Vintage Mustang Forums

 3Likes
Reply
 
Thread Tools
post #16 of 16 (permalink) Old 03-19-2017, 09:26 PM
Senior Member
 
j persons's Avatar
 
Join Date: Aug 2010
Location: Natchitoches, LA
Posts: 1,954
Quote:
Originally Posted by bmcgc View Post
Ive got a 10 year old LT1000 with a 18hp brigs in it. The first battery lasted 4 years, the second 6 years, I just bought the 3rd battery for it.

Today I went to Sears to buy a fuel & air filter and a new gas cap.

I ran out of Sears as fast as my short legs would carry me.

air filter - $42
fuel filter - $12
no gas cap in stock

Lowes had all three items for $22.

I wonder why Sears is going belly up?
I use www.jackssmallengines.com for all my tune up and replacement parts. They are much cheaper than the John Deere dealer for the exact same part.

John

Dynacorn 67 fastback. Dart 363, Close ratio Magnum 6 speed, 3.70 Eaton Truetrac in a fabricated full floater 9", SorT coil over suspension. Still in pieces.
'14 SHO with most all the bells and whistles. Stock for now.
j persons is offline  
Sponsored Links
Advertisement
 
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Vintage Mustang Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off

 
For the best viewing experience please update your browser to Google Chrome