Motor is in...finally! - Vintage Mustang Forums
 
Thread Tools
post #1 of 2 (permalink) Old 06-05-2007, 11:27 PM Thread Starter
Senior Member
 
coolblue65's Avatar
 
Join Date: Nov 2003
Location: Algonquin, IL
Posts: 867
Garage
Send a message via AIM to coolblue65
So I finally got the motor back in the car, I still have LOTS to do, headers, starter, distributor, radiator, alternator, carb...to name a few things! But, nothing 'should' take that long to do. With luck it will be running sometime this weekend.

I took a bunch of pics of the build up:

CLICK HERE TO SEE MORE PICTURES





ET: [email protected] mph
ENGINE: FiTech EFI, DSS 347, AFR 185s, Vic Jr, XE274HR cam, MSD ign, Hooker Headers, Magnaflow exhaust
DRIVELINE: Tremec 3550, Pro 5.0, Fidanza AL Flywheel, McCleod clutch, 3.55's, 13" GT Front & Cobra Rear brakes
SUSPENSION: 17" TTII's, 235/45 tires, 620 coils, Shelby drop, 1" & 3/4" sway bars, Monte Carlo bar, S&T strut rods, Bilsteins, & roller perches
coolblue65 is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 06-06-2007, 12:28 AM
Senior Member
 
Join Date: Jan 2003
Location: WESTERN SUBURBS OF CHICAGO
Posts: 279
Kevin Looks great. Can not wait to see your dino numbers, what it looks like all buttoned up and purring or should I say winning. Dave
wt_stang is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Vintage Mustang Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off

 
For the best viewing experience please update your browser to Google Chrome