79 5.0 tuning issues - Vintage Mustang Forums
 
Thread Tools
post #1 of 3 (permalink) Old 06-19-2019, 10:56 AM Thread Starter
Junior Member
 
Join Date: Mar 2019
Posts: 5
79 5.0 tuning issues

I have a 5.0 with 2 Holley 350cfm carb on top of a Holley sniper high rise intake with a mildly aggressive cam. My issue is that my exhaust smells super rich and spark plugs show a rich burn. My carb it set to roughly stock setting. What else can I troubleshoot should I take a closer look at my timing? Someone told me my spark plugs and wires would be causing a weak spark. Would that cause this issue?
Attached Images
File Type: jpg 20190329_233907_1560956154560.jpg (515.8 KB, 1 views)
Andy0101 is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 06-19-2019, 11:30 AM
Senior Member
 
68Hildago's Avatar
 
Join Date: Jan 2015
Location: Edmonton, Alberta, Canada
Posts: 745
Garage
What are your engine specs? Stroked, aluminum heads, bored over size

I would guess if the engine is fairly stock (besides the cam you mentioned), running 2 350 cfm carbs may be why she is running rich :-)
68Hildago is online now  
post #3 of 3 (permalink) Old 06-19-2019, 12:14 PM Thread Starter
Junior Member
 
Join Date: Mar 2019
Posts: 5
Besides the cam it's all stock. Right now I have one carb basically tuned out of it running progressive linkage
Andy0101 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Vintage Mustang Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off

 
For the best viewing experience please update your browser to Google Chrome