Vintage Mustang Forums - View Profile: watto1

watto1 watto1 is offline

Senior Member

  About Me

  • About watto1
    Biography
    66 Fastback, born as a l6, now '70 302W. 4sp toploader. 600 Holley. PS AC
    Location
    Brisbane Australia
    Interests
    Restoring stuff, motorsport..
    Occupation
    Aircraft Engineer

  Statistics

Total Posts
General Information
  • Last Activity: Today 07:20 PM
  • Join Date: 07-16-2017
  • Referrals: 0

  Mentions

10-09-2019
08:52 PM - myfirstcar66 mentioned watto1 in post Do I need new leaf springs?
...nd don't sag, and watto1, I don't think tire ...

  Quotes

10-10-2019
06:56 PM - 289vert quoted watto1 in post Do I need new leaf springs?
Thanks 4ocious, that's good...
06:52 PM - watto1 quoted tmadden in post Coolant filter anyone used them ?
who carries the tefba in the...
01:19 PM - DonP quoted watto1 in post Do I need new leaf springs?
The axle should hit the bum...
08:42 AM - 4ocious quoted watto1 in post Do I need new leaf springs?
Thanks 4ocious, that's good...
08:22 AM - watto1 quoted 4ocious in post Do I need new leaf springs?
...r is 5560-23.Thanks 4ocious, that's good info, y...
04:50 AM - watto1 quoted DonP in post Do I need new leaf springs?
The axle should hit the b...
10-05-2019
04:48 PM - bobby817 quoted watto1 in post 66 289 2bbl, a/c, p/s Coupe -- Ignition problems STILL
Also..When you checked tdc ...
10-02-2019
02:04 PM - 67 Doctor quoted watto1 in post Engine Question
Here is an excerpt from 'Ja...
09-30-2019
11:57 PM - watto1 quoted Woodchuck in post Battery still leaking / boiling over
http://www.mustangtek.com/Libr...
04:04 PM - mikedela quoted watto1 in post Brake Caliper Piston Compression Question
^ What he said. I can find...
09-28-2019
05:40 PM - watto1 quoted JimGTA in post Tips for door adjustment after a new seal?
Had the same problem with a...
09-26-2019
08:02 AM - Alex Tugbang quoted watto1 in post HELP! Temp Gauge has stopped working! Have tried everything.
Interesting.. Perhaps y...
05:40 AM - awhtx quoted watto1 in post HELP! Temp Gauge has stopped working! Have tried everything.
Yes here is the part number...
09-25-2019
11:40 PM - watto1 quoted Fitch in post HELP! Temp Gauge has stopped working! Have tried everything.
If you have only tried sen...
10:18 PM - Alex Tugbang quoted watto1 in post HELP! Temp Gauge has stopped working! Have tried everything.
Can you confirm that CJs se...
10:12 PM - watto1 quoted Alex Tugbang in post HELP! Temp Gauge has stopped working! Have tried everything.
Ive gone through three and none h...
09:10 PM - Alex Tugbang quoted watto1 in post HELP! Temp Gauge has stopped working! Have tried everything.
Might have cooked the sende...
09:02 PM - watto1 quoted Alex Tugbang in post HELP! Temp Gauge has stopped working! Have tried everything.
I held a lighter to the bottom of...
09-16-2019
09:54 AM - 1968Cally quoted watto1 in post Bad vibrations
How's your transmission mou...
09-09-2019
01:34 PM - Josep quoted watto1 in post Data plate “correction” from factory?
Or repaint.. Sent from m...

  Feedback

iTrader Profile Recent Ratings
Feedback Score:
Positive Feedback:
0
0%
Members who left positive:
Members who left negative:
0
0
Total positive feedback: 0
Submit Feedback
  Past
Month
Past
6 Months
Past
12 Months
Positive Positive 0 0 0
Neutral Neutral 0 0 0
Negative Negative 0 0 0
 
For the best viewing experience please update your browser to Google Chrome