Any recommendations of a good Stereo installer/electrical tech/shop? - Vintage Mustang Forums
 
Thread Tools
post #1 of 3 (permalink) Old 08-16-2013, 02:30 PM Thread Starter
Senior Member
 
Join Date: Aug 2000
Location: NY
Posts: 788
Any recommendations of a good Stereo installer/electrical tech/shop?

Hey all,

I've got a '69 Mustang convertible, that I installed a few years ago a Custom Autosound USA-5 headunit (not what I thought it was going to be...), w/ Changer and External Amp, and a multitude of speaks (6x9s in speaker boxes that can be removed or moved), and kicker panel speakers 4way Pioneers, w/ tweeters on the pillar posts, and a dual voice coil speaker up on the center dash.

I've wire and rewired this system several times, and I am having a lot of issues with the sound, which for some reason still drops out (left and right) channels (like half volume or 1/4 from the other channel), and then if I hit the accelerator it sometimes jumps back to normal (equal levels on both channels). I don't know if its a ground issue or its a head unit problem. I contacted Custom Autosound but they've discontinued this model (w/cassette and changer controls), and said they may not have any parts around to service it...which ticks me off but the quality of those headunits are really lousy since I sent it back to them once already when it was still under warrantee, and I found out from a lot of VMFers and other Mustang owners that they don't recommend them, that Kenwood made a better radio/cassette/headunit and changer setup which I may still have to find one at this rate if I can't get this fixed.

I would like to know if any VMFers in the NY (metro area) could recommend a good troubleshooter of car radios/installations in the area that could possible take a listen to this and find the solution, cause it has to be fixed or reconfiqured or just changed out if I can't get this old setup working. There's nothing worse being on the road with top down and listening to the radio channels dropping out (except maybe static all the feaking time).

Any suggestions are appreciated.
Thanks

Yukon
Yukon is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 08-17-2013, 09:21 PM
Senior Member
 
finbar's Avatar
 
Join Date: May 2012
Location: San Francisco
Posts: 114
A bit off topic, but it sounds like a loose wiring connection.
As the HU is out of warranty open it up and look for loose mechanical/wire connections.
Cold solder joints too. Particularly at heavier components / daughter boards. Reflow where needed.
If none of this seems appetizing get a new HU.

John
1966 289 A code GT coupe C4

http://forums.vintage-mustang.com/signaturepics/xsigpic49255_1.gif.pagespeed.ic.zhUAIxIY-M.jpg
finbar is offline  
post #3 of 3 (permalink) Old 08-18-2013, 02:42 PM Thread Starter
Senior Member
 
Join Date: Aug 2000
Location: NY
Posts: 788
Thanks for the suggestion

Thanks for the suggest on checking the HU internal wiring, and soder connections. I haven't opened up the HU, but I will when I pull it out (yet again). Its out of warrantee and they don't make it any longer (USA-5) w/ cassette and CD controllers.

I hope I can find out what it is without having to install a whole other system.

Thanks
Yukon
Yukon is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Vintage Mustang Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off

 
For the best viewing experience please update your browser to Google Chrome