Chasing brake issues - Vintage Mustang Forums
 
Thread Tools
post #1 of 10 (permalink) Old 06-17-2019, 01:17 PM Thread Starter
Senior Member
 
Join Date: Feb 2015
Posts: 767
Chasing brake issues

Background: my 69 has new rubber lines, new MS, new booster, new calipers, new rotors, and now EBS red pads. It's a disc/drum car

Even after all the new stuff, the brakes have always been lacking on the stopping. I adjusted the push rod by feel which seemed to help, then it went away. The travel in the pedal is long before I get any stopping and I couldn't lock the tires up even if I stood on pedal.

The master cylinder was throughly bled on the bench before install and the brakes have been bled till my leg fell off.

I'm at a loss at what to do. Is the master cylinder bad? The calipers faulty?
bdub4u is offline  
Sponsored Links
Advertisement
 
post #2 of 10 (permalink) Old 06-17-2019, 01:47 PM
Senior Member
 
Join Date: Jan 2016
Location: Chapel Hill, NC
Posts: 1,655
Did you adjust the pushrod between the booster and the master cylinder or do you have an adjustable push rod that's mounted to your brake pedal. The one between the master & booster being out of spec can cause this problem.

If not, then it could be that have a bum master and fluid is bypassing around the piston and not getting full pressure to the pads.

Dan
Chapel Hill, NC
***PM me if you're close by and can lend a hand with my 65 Fastback project***
Dan Babb is offline  
post #3 of 10 (permalink) Old 06-17-2019, 01:51 PM
Senior Member
 
myfirstcar66's Avatar
 
Join Date: Jan 2019
Location: Auburn University, Alabama
Posts: 850
Garage
Was it originally disc or converted? May need a proportioning valve to divide the effort between front and rear, usually about 70 front / 30 rear on street cars.

'66 Tahoe Turquoise/ Aqua coupe
•289 / 4100 •C4 Auto •Disc Brakes
•Dual Exhaust •16:1 Manual Steering
•Rally Pac •Console •Deluxe Belts
•LOTS of Rotunda accessories
•Original Styled Steel Wheels
...my first car

'66 Emberglo / Parchment coupe
•289 / 2100 •C4 Auto •Disc Brakes
•Dual Exhaust •16:1 Power Steering
•Dealer Air Conditioning •Console
...son's first car


myfirstcar66 is offline  
 
post #4 of 10 (permalink) Old 06-17-2019, 02:29 PM
Senior Member
 
Mustang4SF's Avatar
 
Join Date: Jul 2017
Location: Bay Area
Posts: 480
Garage
You mentioned the travel is very long before stopping. Do you have a hard pedal after the travel? Or is it soft all the way? If it is hard after the travel sounds like a push rod issue to me. The proportioning valve avoids locking the rear tires. If you don't have it or wrong adjusted your rear will lock (which is dangerous!). I understood you don't have locking tires at all, so I don't think this is your issue.

Which MS are you using? Can you post more information?



1966 Convertible (Plant: San Jose, CA)
289 2V, PS, AC
Mustang4SF is offline  
post #5 of 10 (permalink) Old 06-17-2019, 02:33 PM
Senior Member
 
vegasloki's Avatar
 
Join Date: Nov 2017
Location: Vegas
Posts: 1,284
Two things come to mind. How did you bleed them? Did you bed the pads? If you don't bed the pads they'll glaze and have a difficult time biting. Long pedal can indicate poor booster vacuum or air in the lines. The way to test is ensure you have good pressure in your brake lines. I don't know of a good, cheap way to test it only with diagnostic gear and that's expensive. If you'e got the right pressure the pads may be glazed.

https://ebcbrakes.com/articles/bedding-in/

EDIT: learned something new, here's an inexpensive way to check pressure

https://www.speedwaymotors.com/Wilwo...SAAEgJOQvD_BwE

67 Hardtop, brought it back to a driver
http://desertratretro.com

Last edited by vegasloki; 06-17-2019 at 02:44 PM. Reason: found brake pressure gauge
vegasloki is offline  
post #6 of 10 (permalink) Old 06-17-2019, 07:41 PM
Just some guy
Supporting Member
 
GypsyR's Avatar
 
Join Date: Jun 2001
Location: SC foothills, USA
Posts: 18,888
Garage
Gee thanks vegas, ANOTHER tool added to my want list.

One neat way to check and see if long pedal travel is an issue with the fronts or rears is to block off the brake line to the rears at the master cylinder and see how the pedal is then. You can take it further by blocking off individual brakes too and even isolation of the master cylinder itself. Companies like Thexton market kits of adapters and plugs just for this. Unfortunately they fit metric stuff, trucks, and etc and so cost like $150 and are way overkill to check out just one car. DIY version is to hit the fittings section of the parts store and with a little creativity you can make your own. Don't crimp rubber hoses for this it tends to damage them internally and add to your problems. Keep in mind that any block offs you make up HAVE to fit perfectly and not leak at all or you are wasting your time.

That said, the most likely suspect I'd be poking at without such tools and right now would be the master cylinder pushrod. You normally don't have to mess with the adjustment of those unless you have a non-standard mismatch of parts.
GypsyR is online now  
post #7 of 10 (permalink) Old 06-18-2019, 03:33 PM Thread Starter
Senior Member
 
Join Date: Feb 2015
Posts: 767
Quote:
Originally Posted by Dan Babb View Post
Did you adjust the pushrod between the booster and the master cylinder or do you have an adjustable push rod that's mounted to your brake pedal. The one between the master & booster being out of spec can cause this problem.

If not, then it could be that have a bum master and fluid is bypassing around the piston and not getting full pressure to the pads.
yes, the pushrod between the booster and master was what was adjusted




Quote:
Originally Posted by myfirstcar66 View Post
Was it originally disc or converted? May need a proportioning valve to divide the effort between front and rear, usually about 70 front / 30 rear on street cars.
it has always been a disc/drum car.

Quote:
Originally Posted by Mustang4SF View Post
You mentioned the travel is very long before stopping. Do you have a hard pedal after the travel? Or is it soft all the way? If it is hard after the travel sounds like a push rod issue to me. The proportioning valve avoids locking the rear tires. If you don't have it or wrong adjusted your rear will lock (which is dangerous!). I understood you don't have locking tires at all, so I don't think this is your issue.

Which MS are you using? Can you post more information?

the travel is soft the whole way through its travel till I pretty much bottom out. it has the factory prop valve for the back. as sated above, its always been a disc/drum car. the rears have never locked up, and either have the fronts other than on a dirt road. the master cylinder (both of them) have came from Orileys. I don't have the part number available off the top of my head, but it was the one that was listed for my particular application. I bench bled the MS with a kit that was provided. I made sure I bled it well above what was necessary to avoid being in a spot of air being trapped in the MS. the system itself on the car was bled in usual fashion, starting with the BR, BL, FR, FL.
bdub4u is offline  
post #8 of 10 (permalink) Old 06-18-2019, 06:18 PM
Senior Member
 
CHOCK's Avatar
 
Join Date: Jul 2003
Location: Illinois
Posts: 3,234
What has been done to the rear brakes? Rear brakes and pedal travel are directly connected. Have you adjusted them correctly?? How did you adjust them?
Are the rears all new? Installed correctly?
If you used a stock master it will have the 10 pound residual valve in the master for rear brakes. If aftermarket it will not. Residual is necessary on rear drum cars (Usually)
Plumbing--Front port of master is rear brakes-Rear bowl master is front brakes..

If you have good fluid flow to rear brakes when bleeding, Proportioning valve is not factor--If Low, little pressure in bleeding mean restrictions in P valve, or distribution block, a bit of trash so to speak.
Short list here of thing to look at.
CHOCK is offline  
post #9 of 10 (permalink) Old 06-18-2019, 08:41 PM
Senior Member
 
Hemikiller's Avatar
 
Join Date: Jun 2002
Location: Killingworth, CT
Posts: 8,714
Garage
Are the rears adjusted up to the drums so they drag?

Which direction to the bleeders on the front calipers point? They should point rearward towards the passenger compartment. If they point vertically, you need to swap them side to side.

Nothing worthwhile is ever quick, cheap or easy, those that can't do, complain

71 Mach 1

HOLLEY TECH PAGES
FORD OE TACH HOOKUP FORD OE TACH HOOKUP w/MSD (pg 7)
Hemikiller is offline  
post #10 of 10 (permalink) Old 06-20-2019, 08:30 AM Thread Starter
Senior Member
 
Join Date: Feb 2015
Posts: 767
Quote:
Originally Posted by CHOCK View Post
What has been done to the rear brakes? Rear brakes and pedal travel are directly connected. Have you adjusted them correctly?? How did you adjust them?
Are the rears all new? Installed correctly?
If you used a stock master it will have the 10 pound residual valve in the master for rear brakes. If aftermarket it will not. Residual is necessary on rear drum cars (Usually)
Plumbing--Front port of master is rear brakes-Rear bowl master is front brakes..

If you have good fluid flow to rear brakes when bleeding, Proportioning valve is not factor--If Low, little pressure in bleeding mean restrictions in P valve, or distribution block, a bit of trash so to speak.
Short list here of thing to look at.

the rear brakes were all rebuilt with new raybestos products. they could probably use some more adjusting now at this point. I adjusted them so they would just barely drag on the drums.

Quote:
Originally Posted by Hemikiller View Post
Are the rears adjusted up to the drums so they drag?

Which direction to the bleeders on the front calipers point? They should point rearward towards the passenger compartment. If they point vertically, you need to swap them side to side.

im 90% sure I installed them correctly since I read before that that's the way they needed to be done. when im home in a few days ill check again.
bdub4u is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Vintage Mustang Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are Off

 
For the best viewing experience please update your browser to Google Chrome