How do I hook up my Odometer? - Vintage Mustang Forums
 3Likes
  • 3 Post By awhtx
 
Thread Tools
post #1 of 8 (permalink) Old 07-12-2019, 08:53 PM Thread Starter
Senior Member
 
ginpunk's Avatar
 
Join Date: Apr 2018
Location: Phoenix Arizona
Posts: 103
How do I hook up my Odometer?

1965 Fastback. C4. 302.

It does not work and I'd like it to work.
ginpunk is offline  
Sponsored Links
Advertisement
 
post #2 of 8 (permalink) Old 07-12-2019, 08:59 PM
Senior Member
 
awhtx's Avatar
 
Join Date: Sep 2011
Location: The Hill Country of Central Texas
Posts: 9,168
The speedometer and odometer are both driven by the same cable. It is not uncommon for one of them to work and the other one to not work. If either one is working your cable is good and the problem lies in the speedometer/odometer mechanism.
NEFaurora, Woodchuck and vegasloki like this.
awhtx is offline  
post #3 of 8 (permalink) Old 07-12-2019, 10:17 PM
Senior Member
 
Join Date: Nov 2018
Location: DFW
Posts: 361
The white crown gear on the odometer wheel is probably split and cracked from age and heat. It's a matter of inspect the speedometer and see what's broken and repair it. Not many speedometer shops left anymore so it's pretty much DIY and find spare speedometers and hope you can get good parts.
elcam84 is offline  
 
post #4 of 8 (permalink) Old 07-12-2019, 10:41 PM
Senior Member
 
67 Fastbacker's Avatar
 
Join Date: Apr 2015
Location: Salem, Oregon
Posts: 188
A quick search ala Google, found several options from video to step by step how to's. One example follows:

https://partsandprojects.com/project...dometer-cable/


67 Fastback, 289, 10.5 comp., H-pipe, Mild Cam,
Edel 1403, C4, PS, PDB, Shelby Drop, GT Coils/Sway Bar

67 Fastbacker is offline  
post #5 of 8 (permalink) Old 07-13-2019, 12:00 AM Thread Starter
Senior Member
 
ginpunk's Avatar
 
Join Date: Apr 2018
Location: Phoenix Arizona
Posts: 103
Thank you. Speedometer works, so....

Quote:
Originally Posted by awhtx View Post
The speedometer and odometer are both driven by the same cable. It is not uncommon for one of them to work and the other one to not work. If either one is working your cable is good and the problem lies in the speedometer/odometer mechanism.
ginpunk is offline  
post #6 of 8 (permalink) Old 07-30-2019, 06:39 PM Thread Starter
Senior Member
 
ginpunk's Avatar
 
Join Date: Apr 2018
Location: Phoenix Arizona
Posts: 103
I took down my instrument cluster, installed a new lens, and general cleaning. Reinstalled and odometer started working - either the crown gear that elcam84 noted above was crusty and stuck, or the cable was not seated all the way.

Regardless, it works.
ginpunk is offline  
post #7 of 8 (permalink) Old 07-30-2019, 07:07 PM
Senior Member
 
Join Date: Nov 2018
Location: DFW
Posts: 361
Don't question it just appreciate it works now and move on. If you do any more it will break for good.
elcam84 is offline  
post #8 of 8 (permalink) Old 08-03-2019, 07:49 PM
Senior Member
 
kenash's Avatar
 
Join Date: Dec 2006
Location: Severna Park, MD
Posts: 6,197
Garage
Yeah........

KenA..
64 1/2 Poppy Red Cvt. Resto-Mod
333 Cu.in. T5z, 3:55, Dual 40 mm DCOE Webers
Performer RPM, CI cam, TFS/TWs, Tri-Ys, Discs w/Shelby Drums
Severna Park, Maryland
kenash is online now  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Vintage Mustang Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are Off

 
For the best viewing experience please update your browser to Google Chrome